Ultimate Tag Warrior 2.0

Okay. I’m somewhat happy with UTW2 now. I’m pretty sure it’s not going to steal your lunchmoney, or anything of that nature, at least.

Something to be aware of, is that even if you have installed a previous version of ultimate tag warrior, you’ll need to visit the installation page; because there are a couple of options which get added. Your head will explode if you forget this! (it probably won’t). By default, the plugin will append links to technorati tag pages at the end of your content; you might not need this, but it’s useful-ish as a starting point if you haven’t used UTW before.

Also, there are now what seems to be two plugins: 1.3 legacy and 2.0. 1.3 Legacy contains all of the functions that the 1.1.2 had, so that everything keeps working; and 2.0 is a cleanslate version which only has functions that use the fancy formatting stuff.

You can also specify the base directory for tags, which is pretty awesome (but I think the admin side will implode if it’s not in the root..)

There’s a readme with instructions for installing in the zip file; and there’s a helpfile in there somewhere which lists out the functions and some stuff for simplified formatting (you can say “commalist” is the kind of formatting, and it dutifully formats it like that; rather than having to wrangle formatting bits directly)

Ultimate Tag Warrior 2.0 go crazy with that thang.

Advertisements

16 thoughts on “Ultimate Tag Warrior 2.0

  1. hi again,
    changed from 1.0 to 2 :-P. i removed all old files from the server and copied the new ones there. after activating the 2.0 plugin i get the errors:

    Warning: main() [function.main]: Unable to access ultimate-tag-warrior-core.php in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 10

    Warning: main(ultimate-tag-warrior-core.php) [function.main]: failed to create stream: No such file or directory in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 10

    Warning: main() [function.main]: Failed opening ‘ultimate-tag-warrior-core.php’ for inclusion (include_path=”) in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 10

    Warning: main() [function.main]: Unable to access ultimate-tag-warrior-actions.php in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 11

    Warning: main(ultimate-tag-warrior-actions.php) [function.main]: failed to create stream: No such file or directory in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 11

    Warning: main() [function.main]: Failed opening ‘ultimate-tag-warrior-actions.php’ for inclusion (include_path=”) in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 11

    Fatal error: Cannot instantiate non-existent class: ultimatetagwarriorcore in /home/www/htdocs/stefan-goehring.net/glatzopatzo/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior.php on line 13

    the files are all there in the utw dir. it should be able to find them. i chmodded the dir and the utw files to 777, but the same result. all i get from my while site when the utw is in the plugin dir are the above mentioned errors, nothing else.

  2. I suggest you include real world examples for the strings. Like, copy this into your loop and this is how you can change it.

    I will need to read the directions further put it does look daunting.

  3. Hi Dan,
    sorry i do not understand what you mean with including real world examples. the include commands in the ultimate-tag-warrior.php?
    include_once(‘ultimate-tag-warrior-core.php’);
    include_once(‘ultimate-tag-warrior-actions.php’);

    the files included exist in the same dir.

    what do you mean with cops this in your loop and this is how i can change it? did you forget to paste your solution? sorry i don’t get it.

    what directions do you mean? i think it’s not daunting how you call it, the script just can’t find the files to include, but i don’t know how to solve this problem.

  4. Dan,

    Gah! I can’t win. The old documentation was too scary, and now this one isn’t scary enough d:

    The easy way, is UTW_whichever(“commalist”); for a whichever list seperated by commas; UTW_whichever(“htmllist”); for a whichever list with the items in li tags; or UTW_whichever(“technoraticommalist”); for a whichever list pointing at the Technorati tag page, seperated by commas.

    (The hard way is much harder (: )

  5. GlatzoPatzo,

    Eep!

    (The issue you were having with UTW1, is that there weren’t any tags yet.. it’s something that I ought to fix so that nothing bad happens. I’m not too sure why things are going terribly for you with UTW2, but if you want to use UTW1 to start tagging your posts; you should be able to upgrade to UTW2 once I figure it out.)

  6. Ah, but first I need to figure out what the problem is (:

    [Worst case scenario, I can make a single-file version for you.]

  7. Couple of bugs (you might already know about them):

    o when I try to save my preferences in Manage -> Tags, it tries to load the url http://mydomain.com/wp-admin/edit.php — however, since my blog is hosted at http://mydomain.com/blog/, this gets a 404. The change needed in -action.php is trivial — instead of hard-coding the script URL, make it a habit of using get_settings(‘siteurl’)/

    o the permalinks don’t get updated properly. In particular, WordPress already rewrites the base properly (so my .htaccess already includes something like RewriteBase /blog/). Now UTW2 creates a rule that tries to match ^blog/tags/ (as specified by the base url in UTW2 preferences). But since WordPress is already taking care of the site base, you should start the RewriteRule for UTW2 with ^tags

    Now I just need the tag cloud back and I’m all set!

  8. Diwaker,

    I’ll bring it back! promise! Figuring out how to get the formatting wrangle to wrangle the tag cloud is harder than I’d thought (: (If you enable the 1.3 legacy plugin, it’s still there)

    [Gah! yeah.. I need to look into the siteurl thing a little harder.]
    [Hadn’t thought about that particular artifact of the updated permalinks.]
    [Gah!]

    (:

  9. Nice and smooth. However, it should automatically appear the sentence “Technorati Tags:” before the tags (just a tip) 🙂

Comments are closed.