Ultimate Tag Warrior 3.141592

Another bug-fix release (:

- Tag feeds are working properly again (: Hopefully.. Depending on the version of wordpress you’re using.. (:
– There are a couple of performance tweaks: There’s a lot less javascript being downloaded most of the time (but with one javascript include for each post if you’re using the magical ajaxy format.. it seems like a worthy compromise!); and if you have a post with no tags, it will be added to the magical cache the first time it’s hit (previously it wasn’t, so there was a tag lookup for each request to a non-tagged page)
– The default category is now being included, if you are using automagic conversion of categories to tags.
– I think that’s it (:

Download here

About these ads

42 thoughts on “Ultimate Tag Warrior 3.141592

  1. Hello Christine,

    have you also included the auto-suggest feature written by one of your commentators? I really want to stay up-to-date with your plugin because I really like it. :-)

    Anyway. My wife was really impressed by your acrobatical skills… :-)

    Roland

  2. I just revamped my website and I installed UTW 3.14159 on a brand new installation of WordPress 2.0.5. It was the only plug-in installed but my pretty permalinks wouldn’t work. Any link on the opening page gave me a “file not found” notice.

    Having tried everything I could think of I deactivated UTW and *bingo* the permalinks worked.

    So I downgraded to UTW 3.01 and now I have permalinks and tags working smoothly.

    I am very happy because 3.01 seems just dandy to me, but I thought I ought to let you know
    :)

  3. I’m back with another trivial problem ;)

    I downgraded to UTW 3.01 (see 8 above) by deactivating the plug-in, removing the folder, putting the new folder in, and activating it. I have just noticed that the result is that the Configuration link in the admin panel doesn’t work. It says “Cannot load ultimate-tag-warrior-actions.php.” which is probably true because the file does not appear to exist in the folder. This doesn’t matter because I only wanted to change the size and colours of my tag cloud and I did this directly in the database instead.

    (By the way you do realise, I hope, that the only reason I am bothering to tell you these things is because UTW is fantastic and something I am rapidly coming to rely on for a lot of things…)

  4. Hi Christine,
    I’ve heard you’re very good with responses…so here goes. This question has been asked a lot before, and it always leads to something on your forum, which is broken :(
    I’m using Ultimate Tag Warrior, the latest one (just downloaded it yesterday). I put a tag cloud on my page, but every time you click a tag link, it just says

    Not Found

    Sorry, but you are looking for something that isn’t here.

    I’m sure there are posts for the tag, but I cant seem to find any.

    Please try and answer my question when you can. I’ve spent all of Saturday trying to fix this.

    Thanks.

  5. Hi Christine,

    First of all compliments to this great plugin! All works very smoothly on the site. When using the Yahoo Tag suggestions I sometimes get an error message saying: “Something done went wrong: object error”. I have been trying to figure out why and what it is but I am stuck :) Do you have any idea what it could be? It happens only with some of the posts and not all of them…

    Thanks!

  6. Can tags on WordPress pages be enabled? I would like to be able to tag pages as well as posts. Any idea how I can enable this? Thanks!

  7. Hey Christine,

    Question: would it be possible to develop a html list for technorati linked tags? Something like…

    technoratihtmllist

    I simply want to list the technorati tags in bullet form, but all you have are comma lists.

    Thanks!

  8. Hello,

    I’ve just discovered your plugin and it’s really great. But when I point to a tag that doesn’t exist, such as “site.com/tags/pizza” and there is no “pizza” tag, I get an error message. Does this happen with anyone else, and is there a fix for it?

  9. Hello Christine,
    Some impressive work you have done, great! Thanks for your plugin.

    However, I (and presumably some others too) have one serious problem with it. I’m using bbPress integrated with Word Press to get the most out of the combination. That means that they share their function namespace. Well, it appears that bbPress has at least one function name, ‘is_tag()’, that is the same with UTW. It loooks like this prevents me from using your plugin at the moment. Do you think, you could reconsider the function names (for example by adding a prefix to them) to avoid this kind of collisions in future?

    I would really like to use your plugin, it’s exactly what I need!

  10. The “tagsetcommalist” has a problem. When I’m using it as the Primary Content Tags (After Content), it displays a comma between everything except the last two tags. Not sure if this applies to other format types as well.

  11. Hi Christine,

    Great plugin… not sure if it’s been reported to you or not, but the tag cloud has problems in IE7. The rendering of the text in the cloud overlaps alot and is cut off in some circumstances.

  12. Hi, i really love that plugin, but could you add tags for BlogBlogs.com.br?

    It’s almost the same configurations for Technorati. I have done it, you can check in any post page of my blog, but i think it would be good have it out of the box.

    BlogBlogs is a brazilian Technorati clone, and is wide used here in Brazil.

  13. Hi,

    I’ve integrated the Ultimate Tag Warrior plugin.
    When I post sg, I can add tags, but it will not appear at the end of the post. Why?

    How can I show what tags I’ve gave?

  14. I’ve run into an issue lately that I’m not quite sure how to fix and wanted to go straight to the source for an answer. I am using UTW as a topic system on a WordPress powered site. However, one of my writers wants a tag to include an apostrophe, like “Alzheimer’s Disease.” Is there any way to allow apostrophes? I see that you are using $tag = str_replace(“‘”, ”, $tag); frequently so I didn’t want to tinker with the file without seeing if there is a straightforward workaround.

    Thanks for your help.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s